Настройка компьютерной сети на основе оборудования CISCO

Это первая статья из серии «настройка коммутационного оборудования CISCO». Сегодня мы рассмотрим реализацию простой компьютерной сети между двумя организациями при условии что основное коммутационное оборудования общее.

Итак задача:

Имеем Две организации (компании, фирмы) сеть которых обслуживается на одном коммутационном оборудовании. В данном случае это Router 911, два коммутатора CISCO 2960 и неуправляемый HUB.

  1. Компании №1 + №2 не должны видеть в сети друг друга, не смотря на то, что в одном сегменте сети у них одинаковая подсеть. (192.168.0.0/24)
  2. Устройства пользователей Компании №1 находятся в разных подсетях. 192.168.0.0 + 192.168.1.0 При этом они должны друг друга видеть в сети.
Схема сети Задание №1

Итак приступаем.

  1. Создаём Vlan на коммутаторах 2960.
    Switch>en
    Switch#vlan database
    Switch(vlan)#vlan 10 Name Company1
    Switch(vlan)#vlan 20 Name Company2
    
  2. Зададим имя нашему Cisco 2960.
    Switch>conf t
    Switch(config)#hostname SW00
    
  3. Теперь назначим портам коммутатора 2960 соответствующие Vlan. Предлагаю поделить поровну, 12 портов для каждой организации.
    SW00(config)#interface range fastEthernet0/1-12
    SW00(config-if-range)#switchport access vlan 10
    SW00(config-if-range)#exit
    SW00(config)#interface range fastEthernet0/13-24
    SW00(config-if-range)#switchport access vlan 20
    SW00(config-if-range)#exit
    
  4. Сразу же переведём два гиговых порта в режим Trunk.
    SW00(config)#interface range gigabitEthernet0/1-2
    SW00(config-if-range)#switchport mode trunk
    SW00(config-if-range)#exit
    
  5. По аналогии с первым CISCO 2960 настроим и второй 2960.
    Switch>en
    Switch#vlan database
    Switch(vlan)#vlan 10 Name Company1
    Switch(vlan)#vlan 20 Name Company2
    Switch>conf t
    Switch(config)#hostname SW01
    SW01(config)#interface range fastEthernet0/1-12
    SW01(config-if-range)#switchport access vlan 10
    SW01(config-if-range)#exit
    SW01(config)#interface range fastEthernet0/13-24
    SW01(config-if-range)#switchport access vlan 20
    SW01(config-if-range)#exit
    SW01(config)#interface range gigabitEthernet0/1-2
    SW01(config-if-range)#switchport mode trunk
    SW01(config-if-range)#exit
    
  6. На этом настройка коммутаторов завершена и мы можем приступить к настройке роутера — маршрутизатора CSICO 911.
    Настроим интерфейс для Компании №1 устройства которой подключены к HUB.
    Router>en
    Router#configure terminal
    Router(config)#hostname R1
    R1(config)#interface gigabitEthernet0/1
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no shutdown 
    
  7. Настроим интерфейс для устройств подключенных к Cisco2960. Мы будем использовать один виртуальный интерфейс «gigabitEthernet0/0.10» для того что бы отлавливать устройства из Vlan 10
    R1>en
    R1#configure terminal
    R1(config)#interface gigabitEthernet0/0.10
    R1(config-subif)#encapsulation dot1Q 10
    R1(config-subif)#ip address 192.168.0.1 255.255.255.0
    R1(config-subif)#description Company1
    R1(config-subif)#exit
    R1(config)#interface gigabitEthernet0/0
    R1(config-if)#no shutdown
    R1(config-subif)#exit
    
  8. Последний штрих. Так как у нас нет DHCP и IP адресация статична, нужно указать устройствам Компании №1 шлюз. Те что подключены к HUB, 192.168.1.1. Те что подключены к Cisco 2960 192.168.0.1

Подключаем провода и проверяем работу. Скачать пример для Cisco Packet Tracer


86