Cisco как настроить NAT

Сегодня мы рассмотрим как быстро настроить NAT на роутере Cisco без лишних настроек и прочего, просто NAT.

Эмуляция задания будет в ПО Cisco Packet Tracer. Итак приступим.

Разместим в рабочую область 3 устройства.

  • Роутер Cisco
  • Компьютер
  • Сервер (будет выполнять роль эмуляции интернет сервисов)

Конфигурация сети у нас следующая:

  1. ПК
    • IP: 192.168.1.10/24
    • GW: 192.168.1.1
    • DNS: 10.10.120.100
  2. Router
    • LAN: 192.168.1.1/24
    • WAN: 10.10.120.1/24
  3. Internet
    • IP: 10.10.120.0/24
    • DNS: 10.10.120.100

Настраиваем ПК по таблице

Ок. Готово

Теперь приступим к настройке нашего роутера

Открываем консоль и пишем следующее

Router>en
Router#conf t
Router(config)#hostname R1
R1#

Это мы сейчас назвали роутер «R1». Теперь настроим интерфейсы

R1(config)#interface gigabitEthernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#description LAN
R1(config-if)#no shutdown 
R1(config-if)#ex

R1(config)#int gig0/1
R1(config-if)#ip add 10.10.120.1 255.255.255.0
R1(config-if)#description WAN
R1(config-if)#no shutdown 
R1(config-if)#ex

В итоге мы имеем два интерфейса 

  1. gigabitEthernet0/0 — для локальной сети, для ПК
  2. gigabitEthernet0/1 — для интернет

Теперь настраиваем на роутере Cisco NAT

R1(config)#access-list 1 permit 192.168.1.0 0.0.1.255
R1(config)#ip nat inside source list 1 interface GigabitEthernet0/1 overload

R1(config)#interface GigabitEthernet0/0
R1(config-if)#ip nat inside
R1(config-if)#exit

R1(config)#interface GigabitEthernet0/1
R1(config-if)#ip nat outside
R1(config-if)#exit

Всё. С настройкой NAT и роутера закончили. (Сохраняем конфиг)

Теперь раз уж мы эмулируем работу сервисов интернет настроим сервер

Проверяем с ПК

Проверяем на роутере

R1#show ip nat translations
Pro  Inside global     Inside local       Outside local      Outside global
udp 10.10.120.1:1025   192.168.1.10:1025  10.10.120.100:53   10.10.120.100:53
udp 10.10.120.1:1026   192.168.1.10:1026  10.10.120.100:53   10.10.120.100:53
tcp 10.10.120.1:1025   192.168.1.10:1025  10.10.120.100:80   10.10.120.100:80
tcp 10.10.120.1:1026   192.168.1.10:1026  10.10.120.100:80   10.10.120.100:80
tcp 10.10.120.1:1027   192.168.1.10:1027  10.10.120.100:80   10.10.120.100:80
tcp 10.10.120.1:1028   192.168.1.10:1028  10.10.120.100:80   10.10.120.100:80
tcp 10.10.120.1:1029   192.168.1.10:1029  10.10.120.100:80   10.10.120.100:80

R1#show ip nat statistics
Total translations: 7 (0 static, 7 dynamic, 7 extended)
Outside Interfaces: GigabitEthernet0/1
Inside Interfaces: GigabitEthernet0/0
Hits: 69  Misses: 49
Expired translations: 38
Dynamic mappings:
R1#

Готово.


Рейтинг: 0/5 - 0 голосов

Комментарии ()

    27